Subject: [Catalina22] CD's topping lift kit

From: "Robert Sparks" <[email-masked]>
Date: Wed, 16 Mar 2005 10:56:47 -0600

Howdy folks,

Has anyone installed the CD topping lift kit? If so, does it work OK and is it worth $60?

Thanks,

Bob

---

From: "Dick King" <[email-masked]>
Date: Wed, 16 Mar 2005 12:16:43 -0500

Hi Bob S. - I have not installed the CD kit.  I am sure it works.  No, IMHO it is not.  Invest your money in a Boom Kicker, or buy a few bucks in a piece of 1/8 inch to tie between the mast head and the outboard end of the boom.  Make it slightly longer than the distance between the two when the boom is hoisted.

Dick King
Melbourne, FL
7976 Jagged Edge
A bad day sailing beats almost anything worth doing.
  ----- Original Message ----- 
  From: Robert Sparks 
  To: Chip's C22 List 
  Sent: Wednesday, March 16, 2005 11:56 AM
  Subject: [Catalina22] CD's topping lift kit

  Howdy folks,

  Thanks,

  Bob

---

From: "Louis Plaisance" <[email-masked]>
Date: Wed, 16 Mar 2005 22:00:03 -0600

Hello Robert,

Well it should work just fine, but I think you can DIY for a lot less.  I bought the downhaul kit from CD and later realized that I could have put it together myself for about half what they charged.  Shopping the ebay auctions can cut expenses if you are patient and don't get caught up in the bidding.  When I really "gotta have it,"  I go to West Marine and pay their price.

ljp
Saint Benedict, #14686
Man....I love that little boat.
  ----- Original Message ----- 
  From: Robert Sparks 
  To: Chip's C22 List 
  Sent: Wednesday, March 16, 2005 10:56 AM
  Subject: [Catalina22] CD's topping lift kit

  Howdy folks,

  Thanks,

  Bob