Subject: Re: [Catalina22] so many toys, so few switches!

From: "Dick King" <[email-masked]>
Date: Thu, 5 May 2005 17:19:09 -0400

Hi Paul- You might be able to combine circuits onto one switch.  What 
circuits are you currently running. I have a 6 switch panel I got from WM. 
See my setup in photo number 13 at  http://tinyurl.com/bjceo.

Dick King
Melbourne, FL
7976 Jagged Edge
A bad day sailing beats almost anything worth doing.
----- Original Message ----- 
From: "Paul Taylor" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 05, 2005 5:05 PM
Subject: [Catalina22] so many toys, so few switches!

| Anyone out there have the lowdown on what switch panel to use when 
upgrading
| an old one?
|
| I fixed my old panel but now I have a bilge pump, anchor light and a depth
| meter. Much more than my 4 switches will accommodate.
|
| CD has an 8 switch panel but it is an astounding 150 bucks and it is not 
in
| stock.
| Surely there is a 7 inch panel out there that is much less?
|
| Paul Taylor
| Myrtle Point, OR
| 5431 Respite
|
|
|
|
| ------------------------------------------------------------------------------------
| For information on unsubscribing or contacting the list owner, go to:
| http://chipford.com/list/instructs.htm 

------------------------------------------------------------------------------------
For information on unsubscribing or contacting the list owner, go to:
http://chipford.com/list/instructs.htm

---

From: "Paul Taylor" <[email-masked]>
Date: Thu, 5 May 2005 14:05:32 -0700

Anyone out there have the lowdown on what switch panel to use when upgrading
an old one? 

I fixed my old panel but now I have a bilge pump, anchor light and a depth
meter. Much more than my 4 switches will accommodate. 

CD has an 8 switch panel but it is an astounding 150 bucks and it is not in
stock. 
Surely there is a 7 inch panel out there that is much less?

Paul Taylor
Myrtle Point, OR
5431 Respite

---

From: "Gregory R. Bover" <[email-masked]>
Date: Thu, 5 May 2005 17:51:05 -0400

Where's Randy's site? My old link doesn't work, I haven't been there in a
while.

Greg Bover
Pensive Flyer
1974 C-22 #3443
Magnolia, Mass

Gregory Bover
V.P. Operations
C. B. Fisk, Inc.
21 Kondelin Rd, Gloucester MA  01930  USA
978.283.1909  FAX 978.283.2938
[email-masked]   http://www.cbfisk.com/welcome.html
----- Original Message ----- 
From: "Ken Palmer" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 05, 2005 5:39 PM
Subject: Re: [Catalina22] so many toys, so few switches!

> I used a Blue sea's 8 breaker panel when I upgraded the panel in Last
Penny.
> Works for me and its a true Breaker Panel. I also moved it. Pictures are
on
> Randy's site.
> ~~~_/) ~~~
> Ken Palmer
> "Last Penny"
> C22 #10475
> Sent: Thursday, May 05, 2005 4:05 PM

---

From: "Ken Palmer" <[email-masked]>
Date: Thu, 5 May 2005 16:39:06 -0500

I used a Blue sea's 8 breaker panel when I upgraded the panel in Last Penny. 
Works for me and its a true Breaker Panel. I also moved it. Pictures are on 
Randy's site.

~~~_/) ~~~
Ken Palmer
"Last Penny"
C22 #10475

---

From: "Dennis Slaton" <[email-masked]>
Date: Thu, 5 May 2005 18:05:23 -0400

Hi Paul, CD prices floor me sometimes, I can't believe how spendy they are. 
That why I only buy the chainplate upgrade and the spreader partner upgrade 
from them, the things I can't get anywhere else. Find a HELLA dealer in your 
area, they make several switch panels for the marine industry, that are high 
quality.
Dennis Slaton
Tar Baby # 27