Subject: Re: [extropy-chat] Re: TransColloquium Meeting: Dealing with New Pope's Campaign

From: Mike Lorrey <[email-masked]>
Date: Wed, 27 Apr 2005 10:56:41 -0700 (PDT)

--- "Eliezer S. Yudkowsky" <[email-masked]> wrote: 
> > What I think we should be focusing on is Benedict's likely focus on
> > bioethics:
> > 
> >
>
http://cyborgdemocracy.net/2005/04/ratzinger-on-genetic-enhancement-and.html
> 
> Agreed.  From my perspective moral relativism is a complex
> philosophical 
> confusion, something that needs to be explained more than fought. 

Quite so, and packaged such that transhumanism is a more objective, not
less objective, moral stance, than bioluddism.

If you want to win the argument, you must argue from theology, not
marxist dogma or post-modern philosophy.

Mike Lorrey
Vice-Chair, 2nd District, Libertarian Party of NH
"Necessity is the plea for every infringement of human freedom.
It is the argument of tyrants; it is the creed of slaves."
                                      -William Pitt (1759-1806) 
Blog: http://intlib.blogspot.com

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
_______________________________________________
extropy-chat mailing list
[email-masked]
http://lists.extropy.org/mailman/listinfo/extropy-chat

---

From: Samantha Atkins <[email-masked]>
Date: Wed, 27 Apr 2005 14:13:32 -0700

> marxist dogma or post-modern philosophy.

Huh?  Theology?  Please explain.

- samantha