Subject: [Catalina22] old switch panel wireing

From: "Paul Taylor" <[email-masked]>
Date: Mon, 25 Apr 2005 20:18:52 -0700

I am Paul Taylor, proud new owner of a 1976 C-22 . I bought a new battery
for my
boat the other day and hooked it up with absolutely no results. I tracked
the problem down to corroded switches and fuses. I took them apart, replaced
the switches with new ones and cleaned up the fuse holders so they will work
fine now. My problem is... I didn't take a picture my stock switch panel
before dismantling it.
Does anyone know where I can find a picture of an old switch panel that is
wired up properly?

Thanks,

Paul Taylor
Respite 5431
Myrtle Point, OR

------------------------------------------------------------------------------------
For information on unsubscribing or contacting the list owner, go to:
www.chipford.com/list_instructs.htm

---

From: "Dick King" <[email-masked]>
Date: Tue, 26 Apr 2005 00:24:14 -0400

Hi Paul - I am wondering if the fuses and switches were badly corroded, how 
is the wiring.  I completely replaced mine (1978) as the old stuff had long 
since turned to green dust.  Here is a source of wiring diagrams for switch 
panels  You will note that each device is fed positive by individual 
switches and the returns are led to a buss bar. 
http://www.slowflight.net/upgrades/toc-elec.html

Good luck with the project.

Dick King
Melbourne, FL
7976 Jagged Edge
A bad day sailing beats almost anything worth doing.
----- Original Message ----- 
From: "Paul Taylor" <[email-masked]>
To: <[email-masked]>
Sent: Monday, April 25, 2005 11:18 PM
Subject: [Catalina22] old switch panel wireing

|I am Paul Taylor, proud new owner of a 1976 C-22 . I bought a new battery
| for my
| boat the other day and hooked it up with absolutely no results. I tracked
| the problem down to corroded switches and fuses. I took them apart, 
replaced
| the switches with new ones and cleaned up the fuse holders so they will 
work
| fine now. My problem is... I didn't take a picture my stock switch panel
| before dismantling it.
| Does anyone know where I can find a picture of an old switch panel that is
| wired up properly?
|
| Thanks,
|
| Paul Taylor
| Respite 5431
| Myrtle Point, OR
|
|
|
|
|
|
| ------------------------------------------------------------------------------------
| For information on unsubscribing or contacting the list owner, go to:
| www.chipford.com/list_instructs.htm
|

---

From: Noel Walker <[email-masked]>
Date: Tue, 26 Apr 2005 23:56:52 -0400

Hi Paul.

I am also rebuilding my switch panel on my 84 C22.  As I understand it
you need to lead one side of your master switch to the positive post
on the battery and the other one gets split between the LED on the
panel and the positive bus that connects all the fuses together. 
After that each fuse goes over the top and connects with a switch on
the opposite side of the panel.  You then connect each of your devices
there.

I have posted pix on my website
(http://mrwalker.homestead.com/proj_panel.html) and they probably do a
better job of explaining what I'm trying to say.

If you have any specific questions feel free to email me off line or
reply to the group.  Good Luck

_______________________

Noel Walker
Mark Twain
1984 C22 #12154

"We will see Him as He is!"
1 Jn 3: 2
_______________________