Subject: Re: [Catalina22] old switch panel wiring

From: "Paul Taylor" <[email-masked]>
Date: Mon, 25 Apr 2005 22:59:38 -0700

Thanks Dick,

They were badly corroded but I replaced the switches with new ones and
cleaned up the fuses and holders so they all work. The schematics you
pointed me too are not exactly what I have on my boat. You can see what I
have at www.paulspc.com/powerbox.jpg .

The wiring on the boat seems to be ok. Will know more when I get the box
wired correctly. It looks like the wireing has been replaced withing the
last 10 years or so.

If you will take a moment and look at my panel, I would like to know where
the main switch wires go to and how the light is supposed to be hooked up.
Also there are two wires on the buss that I have no clew where they should
go.  I am not electrically inclined but am willing to learn.

Any help would be appreciated.

Paul Taylor

On 04/25/2005 9:24:14 PM, [email-masked] wrote:
> Hi Paul - I am wondering if the fuses and switches were badly corroded,
> how
> 
> is the wiring.  I completely replaced mine (1978) as the old stuff had
> long
> 
> since turned to green dust.  Here is a source of wiring diagrams for
> switch
> 
> panels  You will note that each device is fed positive by individual
> 
> switches and the returns are led to a buss bar.
> 
> http://www.slowflight.net/upgrades/toc-elec.html
> 
> 
> 
> Good luck with the project.
> 
> 
> 
> Dick King
> 
> Melbourne, FL
> 
> 7976 Jagged Edge
> 
> A bad day sailing beats almost anything worth doing.
> 
> ----- Original Message -----
> 
> From: "Paul Taylor" <[email-masked]>
> 
> To: <[email-masked]>
> 
> Sent: Monday, April 25, 2005 11:18 PM
> 
> Subject: [Catalina22] old switch panel wiring
> 
> 
> 
> 
> 
> |I am Paul Taylor, proud new owner of a 1976 C-22 . I bought a new
> battery
> 
> | for my
> 
> | boat the other day and hooked it up with absolutely no results. I
> tracked
> 
> | the problem down to corroded switches and fuses. I took them apart,
> 
> repla

------------------------------------------------------------------------------------
For information on unsubscribing or contacting the list owner, go to:
www.chipford.com/list_instructs.htm

---

From: "Chip Ford" <[email-masked]>
Date: Tue, 26 Apr 2005 11:59:44 -0400

1974 Catalina 22  ▪  Swing Keel  ▪  # 3282
Chip Ford  ▪  Marblehead, Massachusetts  ▪  781-639-9709
Visit the Chip Ahoy website <http://www.chipford.com/> 

  _____  

See:   <http://chipford.com/electrical.htm> Catalina 22 Electrical Diagrams. 

Chip Ford <http://www.chipford.com/list/members.htm#Chip_Ford>  --

Paul Taylor wrote:

I am Paul Taylor, proud new owner of a 1976 C-22 . I bought a new battery for my boat the other day and hooked it up with absolutely no results. I tracked the problem down to corroded switches and fuses. I took them apart, replaced the switches with new ones and cleaned up the fuse holders so they will work fine now. My problem is... I didn't take a picture my stock switch panel before dismantling it. Does anyone know where I can find a picture of an old switch panel that is wired up properly?

 ――――  Discussion List Member Services <http://www.chipford.com/list/services.htm>   ――――

  _____  

For information on unsubscribing or contacting the list owner, click  <http://www.chipford.com/list/instructs.htm> here