Subject: [AthofSV] Ellen Johnson on Larry King Live

From: "Mark W. Thomas" <[email-masked]>
Date: Fri, 15 Apr 2005 09:53:53 -0700

godless,

Ellen was great last nite on Larry King Live - personable, friendly,
intelligent, rational, eloquent, and of course, good-looking (hey, it
helps).  The biggest problem she had was not getting much time to counter
all the religious blather that the others put forth (without an iota of real
evidence).  The odds were stacked against her 5 to 1, and she was up to it.

It was astounding how the xtians didn't realize how rude they were by
insulting the Jewish rabbi and the Muslim.  The Protestant agreed with the
Muslim on a point, then went on to say something about Jeezus.  They just
can't help it.

If anybody wants a copy, gimme a tape and I'll make one for you.

 - Mark

------------------------ Yahoo! Groups Sponsor --------------------~--> 
Would you Help a Child in need?
It is easier than you think.
Click Here to meet a Child you can help.
http://us.click.yahoo.com/0Z9NuA/I_qJAA/i1hLAA/OzVolB/TM
--------------------------------------------------------------------~-> 

Sat. 4/16, 2:00 - "Ethicology: Proposing a New Science of Moral Imperatives"
   by Richard Carrier, in Berkeley
Wed. 4/27, 7:30 - An Atheist's Guide to Objectivism
Thu. 5/5, 11:15 - PROTEST of the National Day of Prayer, at SJ City Hall
Wed. 5/25, 7:30 - Women's Voice From the East: speech on Taslima Nasrin

Everyone is welcome at our meetings.

Subscribe to Atheist News Service -
email [email-masked] with: name, address & phone #

If you're not worried, you're not paying attention.

ASV Library at meetings: bring books & magazines; get books and magazines.
See our website http://www.godlessgeeks.com

Keep the msgs to Atheist topics.
Help keep email overflow down. Make your posts short; clean out old text in any responses that you make.

If you want to join a liberal political discussion, see [email-masked]

To unsubscribe, send an email to:
[email-masked] 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/athofsv/

<*> To unsubscribe from this group, send an email to:
    [email-masked]

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/

---

From: Gillian Altieri <[email-masked]>
Date: Fri, 15 Apr 2005 17:14:34 -0700 (PDT)

Hi, Mark,

I saw it too and I agree with your assessment. Ellen
came off as the most tolerant of the group. The
Catholic priest had that smile of discomfort sitting
between the fundy and the rabbi. The fundy came off as
the most intolerant of the group. The rabbi said
something interesting in that God doesn't open the
door to heaven based on belief, but by good deeds done
during life, even to non-believers. The fundy looked
like he had just eaten a bug. It was also interesting
that the Muslims don't think of Jezeus as divine, yet
they do believe he was the result of a virgin
birth...?

Larry King was great when he loudly stated to the
theists,"But you don't REALLY KNOW what happens after
you die, do you?" 
 
When Ellen said that she was brought up in an atheist
household, I wonder if it might add to the atheist
position in the future to also have an atheist who was
once a theist(and came to their senses).

Gillian

__________________________________ 
Do you Yahoo!? 
Yahoo! Small Business - Try our new resources site!
http://smallbusiness.yahoo.com/resources/