Subject: RE: [Immortality_Club_40271] OT US Debt

From: "Shawn Fox" <[email-masked]>
Date: Thu, 28 Apr 2005 13:20:34 -0500

Considering that republicans pay most of the taxes we don't give a crap how much the US govt owes.  The only thing I care about is how much of the money I work hard for that I get to keep.  If you want to pay higher taxes I'm sure the government is quite willing to accept any additional money you want to send them.  I don't mind paying taxes for things like roads, military, police, etc.  It is the vast majority of my money that I pay which is just redireced to those less able and in some cases less fortunate, but that is life, some people get screwed.

I'd love to see a balanced budget.  If we would just get rid of these socialist programs like Medicare we could pay off that $7.8 trillion in "debt" in a short period of time.  It isn't low taxes that cause debt it is excessive spending.

Your claim that Republicans control both taxes and spending is totally invalid.  Most government spending is in the form of entitlement programs not in the form of programs that can actually be cut.  Just watch what happens as we try to fix the social security system.  Bush's proposals make perfect but will fail because they are easy to campaign against.  The only other valid option is to raise the retirement age and that isn't going to happen either.  You think we should just raise taxes?  How is that fair?  The baby boom generation only had to support 1 retiree for every 3 to 5 workers and my generation has to support one retiree for every 2 workers?  Something must be done other than raising taxes.

It is not republicans or democrats who are responsible for the unbalanced budget.  It is a political system that rewards politicians for spending money and punishes them for increasing taxes.

I'm not even going to discuss Clinton's "balanced" budget.  Anyone that doesn't have their head stuck up their butt knows he didn't have a damn thing to do with it other than signing laws passed by a Republican congress.  He was just an expert politican who did what all politicians try to do: Claim good results as your own and blame bad results on the opposite party.

Personally I dislike both political parties here in the US.  Both of them just pander to their base instead of doing the right thing.  The Democrats raise taxes on people who don't vote for them and give them money to those who do.  The Republicans lower taxes on those who vote for them and force their religious views on the rest of the country.  It is all a big mess.  Anyone who thinks their party is "clean" or somehow "better" is a damn fool.  Both parties in general care only about getting re-elected not about doing the right thing for the country.  We are very fortunate that we have maintained the one thing that does truly matter for long term economic success, those who work hard or have special abilities are rewarded with a larger share of the overall wealth.

----Original Message Follows----

From: "chrisclub" <[email-masked]>

Reply-To: [email-masked]

To: [email-masked]

Subject: [Immortality_Club_40271] OT US Debt

Date: Thu, 28 Apr 2005 07:04:52 -0000

These numbers mean nothing to Republicans?

When the Republicans are charge of the tax rate and spending amount,

this is what happens...

Today, the US owes almost 4 times it's annual income.

The US Debt today is $7.8 Trillion.

The US debt was less than $1 Trillion when Reagan decided we no

longer have to collect enough tax to pay our bills... we can just

borrow the difference.

This year the US will take in $2.0 Trillion in taxes, spend $2.5

Trillion, and borrow another $500 billion to make up the difference.

This year the US will spend $400 billion on interest on the US debt.

Chris

Yahoo! Groups Links

To visit your group on the web, go to:
http://groups.yahoo.com/group/Immortality_Club_40271/

To unsubscribe from this group, send an email to:
[email-masked]

Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.

---

From: "Shawn Fox" <[email-masked]>
Date: Thu, 28 Apr 2005 13:27:20 -0500

the other issue I wanted to mention in my previous reply was that the with the low interest rates the US government pays on debt it makes sense to borrow.  The 10 year tbill rate is currenty at 4.2%.  With inflation kicking along at about 3% and economic growth also at 3%, it is actually better to continue to borrow money than it is to increase taxes to pay off the debt.  Higher taxes have a negative impact on economic growth and can actually make things worse, not better.

Obviously cutting spending is the best solution but if either political party makes serious efforts to cut entitlement spending they will get thrown out of office for the next 20 years.

----Original Message Follows----

this is what happens...

borrow the difference.

Chris

Yahoo! Groups Links