Subject: [Catalina-22] [Tech] c22 vs C25 C27 bigger boats

From: Tom Wetsel <[email-masked]>
Date: Wed, 22 Aug 2007 05:32:13 -0700 (PDT)

1) I forgot to change the subject line before, sorry. 

2)  I think if you are happy with the C22 you will be happy with the Catalina line of boats.  The C27 continues the look, provides the long cockpit, and continues the concept of value for money.  

3) Ebay Catalina 25s   

One in NC for $500, Moorehead city.  Need fiberglass or Epoxy work, but the outboard looks great, roller furling,,,.  The list ought to but it and form a coop and buy it with weeks dates for sailing, Moorehead city is a good sailing point.  We could all stand a week on a C25.  

OT  It has just been hot, hot hot hear, but lots of clear sailing days. I saw New England was cool, o well. 

One in FL for $1000.

Tom Wetsel <[email-masked]> wrote: I have a C22 and a C27.  

The 27 is great sails like a dream and is apartment sized compared to the C22 below decks.  It has a head, shore power, lots of real sleeping room for people.  Of course it does not fit very well on a trailer.  You can buy a C27 for about the price of a C25. 

You saw the video of 20-25 knots the C27 would handle it easily, however I turn around at 25 knots because the seas start coming over the bow, some may think that is fun, but not me. 

[email-masked] wrote: Who sent the e-mail mentioning they raised the mast on their C22 and a C25?
  Sorry, I can't find it but am interested to hear from someone who owned both models their opinions of the sailing characteristics of the C22 versus the C25. 
   
  Glenn  Hedmark

Skip Meisch <[email-masked]> wrote:
  
http://slowflight.net/upgrades/tips-GinPole.html

---

From: "Jim Holliday" <[email-masked]>
Date: Wed, 22 Aug 2007 09:13:52 -0500

My kill switch on my 83 4.5 hp Evinrude stopped working.  Is there any
harm to a two cycle engine using the choke to stop it running?
 
Jim Holliday
74 Cat 22, swing keel, #3436
"Gandalf"
Grand Lake Sailing Club, NE Oklahoma

---

From: [email-masked]
Date: Wed, 22 Aug 2007 10:44:22 -0400

I stop most of my lawn 2 cycle motors by choking them out.? Have been doing this for years.? Never had any problems by doing so.

Don't you have a dead man switch/lanyard ? might be a good time to test it.

Many people just run the motor out of fuel to keep the carb bowl dry, which helps keep things from fuel varnish ... it may be a better idea when you are away from the boat for more than a few days.

In the fall or over the winter you can fix the switch. I would guess it is no big deal to fix it.

Bill Bell
#13784, Phoenix
87sk, FL

 

-----Original Message-----
From: Jim Holliday <[email-masked]>
To: [email-masked]
Sent: Wed, 22 Aug 2007 10:13 am
Subject: RE: [Catalina-22] [Tech]  Choking outboard to kill

My kill switch on my 83 4.5 hp Evinrude stopped 
working.? Is there any harm to a two cycle engine using the choke to stop 
it running?

?

Jim Holliday
74 Cat 22, swing keel, 
#3436
"Gandalf"

________________________________________________________________________
Check Out the new free AIM(R) Mail -- Unlimited storage and industry-leading spam and email virus protection.