Subject: [Catalina-22] [GENERAL] Production swing vs. wing

From: [email-masked]
Date: Wed, 11 Jul 2007 14:11:14 -0500

I'm just curious, does anyone know the production numbers of wing vs. swing vs.
fin keels?

Jim McGee
94 C22 5332
Maple Shade, NJ

---

From: "Ken G. Brown" <[email-masked]>
Date: Wed, 11 Jul 2007 17:49:31 -0600

Best info I have found on the subject:
<http://catalina22fleet20.home.comcast.net/techtips/sailnumbers.htm>

Ken

Ken G. Brown, Leduc, Alberta, Canada
1988 C22 Swing Keel #14764 - CTYH4764F888 - Sail# 103

--