Subject: Re: [Catalina-22] [TECH] stripping teak finish

From: [email-masked]
Date: Fri, 20 Apr 2007 23:32:23 +0000

Jon
      I remove mine most of the wood is easy to remove. A random orbit sander works wonders I have been varnishing with 7 coats I like gloss finish but it does not last too long. The next year a light sanding and coat once more.

Scott Harding
1988 Swing Keel Adagio
CTYH4284G788

-------------- Original message -------------- 
From: "Jon Golliher" <[email-masked]> 

I'd like to make the teak on Happy Daze presentable and I need lots of direction.

A lot of it is bare and weathered which I'd prefer all over but there are some large, thick patches of some yellowish finish (Cetol?) on everything.

I'd prefer a uniform weathered finish but an oiled finish would be the next preference.

I'd first thought of hand sanding the patches but they are so thick and I'd still not get the finish out of the grain.   

I want to do the work without taking the teak off because I sometimes do more damage than I fix.     Whomever first said "Don't fix it if it ain't broke" must have known me well. LOL

Is there a recommended stripper to use for the results I want?    I plan to mask off the gelcoat to protect it and help with cleanup.

Any and all comments are appreciated as I'm totally ignorant of what I'm attempting to do.

Many thanks in advance!

Fair winds,
Jon Golliher
'85  SK  12712
Happy Daze
Anderson, IN

---

From: "Jon Golliher" <[email-masked]>
Date: Fri, 20 Apr 2007 21:25:12 -0400

Scott, 

Thanks for the reply.   

I intended to take it all off the winter I bought Happy Daze and  quickly decided it wasn't just unscrewing a few screws and removing the pieces.    Mine has wood plugs to remove and replace that are behind most if not all the screws.

Also, I didn't mention I intend on doing the work in some gunkholes or at the dock when the mood strikes and any sanding will be by hand.    Also as I mentioned sanding will level the finish and still not get it out of the soft grain as I was thinking some kind of stripper might come closer to doing.

I also prefer the bare, weathered look of teak or oiled finish.   Just personal preference.

Maybe I'm just not making myself clear.

Thanks again,
Jon Golliher
'85  SK  12712
Happy Daze
Anderson, IN

  ----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked] 
  Sent: Friday, April 20, 2007 7:32 PM
  Subject: Re: [Catalina-22] [TECH] stripping teak finish

  Jon

  Scott Harding
  1988 Swing Keel Adagio
  CTYH4284G788

    -------------- Original message -------------- 

    Many thanks in advance!

    Fair winds,
    Jon Golliher
    '85  SK  12712
    Happy Daze
    Anderson, IN