Subject: Re: [ExI] Psychology Today Article: The Boy Who Wants to LiveForever...

From: "George Dvorsky" <[email-masked]>
Date: Wed, 9 May 2007 12:41:40 -0400

Is there a Web link for this yet?

George
_______________________________________________
extropy-chat mailing list
[email-masked]
http://lists.extropy.org/mailman/listinfo.cgi/extropy-chat

---

From: "Michael Anissimov" <[email-masked]>
Date: Wed, 9 May 2007 09:45:33 -0700

On 5/9/07, Henrique Moraes Machado (oplnk) <[email-masked]> wrote:
>
> Indeed. The only bad thing I can say about Dr. de Grey is that he speaks
> insanely fast :-)

Aubrey de Grey is one of the only people I know who I think speaks
*fast enough*.  The other is Michael Vassar.  Listening to people talk
is so much slower than typing and reading, we should minimize the
disadvantage of speech by talking very rapidly.

-- 
Michael Anissimov
Lifeboat Foundation      http://lifeboat.com
http://acceleratingfuture.com/michael/blog
_______________________________________________
extropy-chat mailing list
[email-masked]
http://lists.extropy.org/mailman/listinfo.cgi/extropy-chat

---

From: "spike" <[email-masked]>
Date: Wed, 9 May 2007 14:31:07 -0700

> Indeed. The only bad thing I can say about Dr. de Grey is that he speaks

I admire that about AdG.  Listening to a person speaking is so I/O bound.  A
typical listener can think circles around a typical speaker.  Speaking so
bandwidth limited, oy.

spike