Subject: Re: [extropy-chat] Wikipedia page and cryonics

From: Eugen Leitl <[email-masked]>
Date: Wed, 11 Apr 2007 21:06:27 +0200

On Wed, Apr 11, 2007 at 01:53:06PM -0400, pjmanney wrote:

> While I understand your historical argument, transhumanism isn't just about cryonics.  

Cryonics is a nice way of putting your money where your mouth is. Also, because
it doesn't look as if life extension will achieve escape velocity in our biological
life time, cryonics is the only option if you want to sample the transhuman
future in person. The only option. There is no other, currently.

> I agree with both Justice DeThezier's argument on WTA-talk (since I also said 'no') 

No one is compelled to do it (since I don't live in the area with any coverage
I'm not signed up myself).

> and Loremaster's rationale for discretion.  Cryonics status -- or any other personal 

Loremaster's comment sounded remarkably uninformed, and inflammatory.

> status -- should not be a matter of public record, unless the individual requests it.
> 
> Otherwise, it smacks of marketing or other hidden agendas.

To me, it sounds like the person is sufficiently comitted (or reasonably well-off),
and/or willing to support the current institutions, considering them reformable.

-- 
Eugen* Leitl <a href="http://leitl.org">leitl</a> http://leitl.org
______________________________________________________________
ICBM: 48.07100, 11.36820 http://www.ativel.com http://postbiota.org
8B29F6BE: 099D 78BA 2FD3 B014 B08A  7779 75B0 2443 8B29 F6BE
_______________________________________________
extropy-chat mailing list
[email-masked]
http://lists.extropy.org/mailman/listinfo.cgi/extropy-chat

---

From: Eugen Leitl <[email-masked]>
Date: Fri, 13 Apr 2007 09:22:06 +0200

On Thu, Apr 12, 2007 at 05:19:47PM -0400, Heartland wrote:

> How do you know they are procrastinators? Maybe they haven't signed up yet because 

Because it's a chronical malaise of the fringe crowd.

> they don't believe this would change anything.

I'm not signed up because there's no coverage in my patch
of the geoid. You can be damn sure I would if I knew I'd
get a crack at a halfway decent suspension.