Subject: Re: [Catalina-22] [general]

From: Ricky L Carroll <[email-masked]>
Date: Fri, 13 Apr 2007 07:00:45 -0700 (PDT)

I can't imagine towing a trailer/boat over 3000lbs. without brakes. I similar concerns about towing a 3000lb package on anthing but a frame mounted hitch, even with a HD truck bumper setup.

Btw, in many states, any tow over 2000lbs is required to have brakes. I prefer electrics, but surge brakes work fine in all but really long down-grades and they are much more "marine friendly".

Atwood surge systems can be easily retro-fitted to most any trailer.

Ricky
Aeolia
15552
2005 Sport

----- Original Message ----
From: Ken G. Brown <[email-masked]>
To: [email-masked]
Sent: Thursday, April 12, 2007 11:17:28 PM
Subject: Re: [Catalina-22] [general]

.........Trailer brakes are essential for safety in my opinion, especially if driving on hills, and very reassuring under any conditions if you need to stop quickly during an emergency.

Ken

Ken G. Brown, Leduc, Alberta, Canada
1988 C22 Swing Keel #14764 - CTYH4764F888 - Sail# 103

>I have never put 10% on any hitch intentionally.  That would be nearly 300 pounds on a C22..

---

From: "Ken G. Brown" <[email-masked]>
Date: Fri, 13 Apr 2007 12:07:09 -0600

I have electric brakes and did quite a bit of looking before buying a controller. I got one that senses brake line pressure from the master cylinder and thereby gives good proportional control. There appear to be advances lately that do not require a brake fluid pressure sensor but still give good proportional control.
<http://www.brakecontroller.com/?OVRAW=RV%20trailer%20brake%20controller&OVKEY=rv%20trailer%20brake%20controller&OVMTC=standard>

Ken

--