Subject: Re: [Fwd: Re: Translation instructions for Darwin Day]

From: NSK <[email-masked]>
Date: Fri, 20 Oct 2006 02:38:18 +0300

On Friday 20 October 2006 02:10, you wrote:
> For logging into ftp.darwinday.org with the FTP program, the account
> name is [email-masked] and the password is "theta".
>
> Good luck,
>
>   - David

Thanks! :)

Nikolaos S. Karastathis

---

From: Translation coordinator <[email-masked]>
Date: Thu, 19 Oct 2006 23:10:31 +0000

Good luck,

  - David